Operators are unable to Engage with Visitors

Incident Report for Glia

Resolved

This incident has been resolved.
Posted Sep 27, 2023 - 15:04 UTC

Monitoring

Our operations team has identified the issue and are monitoring the system.
Engagements are working as expected in all channels
Posted Sep 27, 2023 - 14:51 UTC

Identified

Some customers are seeing engagements not connecting and visitors unable to enqueue. We’re aware of the issue and are working on it urgently.

Please know our teams are working hard to get everything up and running, and we will update as we have new information or within the next 60 mins.
Posted Sep 27, 2023 - 14:47 UTC
This incident affected: Overall System Status Americas.