Infrastructure Service Provider Reporting Service Disruption Affecting Glia Engagement Routing

Incident Report for Glia

Resolved

The incident has been fully resolved with all instances fully functional and performing as expected.
Posted Oct 20, 2025 - 22:57 UTC

Monitoring

We have implemented a fix and are monitoring the system as it recovers. We are continuing to monitor the issue.
Posted Oct 20, 2025 - 22:38 UTC

Identified

The system is recovering. Our engineering team is working on clearing out stuck engagements. Our expected time to completion is 20 min.
Posted Oct 20, 2025 - 22:35 UTC
This incident affected: Overall System Status Americas and Overall System Status EU.