Phone Service Provider reporting service disruption affecting Glia
Incident Report for Glia
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 21:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2024 - 21:12 UTC
Identified
Our Phone Service Provider has reported service disruption affecting phone engagements.

We are communicating and monitoring closely the incident and the developments to fix it.
Posted Feb 14, 2024 - 20:59 UTC