Service disruption of Glia Platform affecting engagements
Incident Report for Glia
Resolved
The operations team has implemented a fix and the system is fully operational
Posted Dec 18, 2023 - 16:16 UTC
Identified
The issue has been identified and we are urgently working on resolving the issue.
Visitors are experiencing delays while waiting to connect with an Agent
Posted Dec 18, 2023 - 16:04 UTC
This incident affected: Communications.