Our service provider has reported that service has been restored, telemetry and monitoring shows that Glia Engagement Routing works as expected.
Posted Oct 20, 2025 - 21:08 UTC
Monitoring
We continue to communicate with our service provider to monitor the incident closely and follow their developments to fix it.
Posted Oct 20, 2025 - 20:40 UTC
Update
We are actively assessing the specific scope of this service interruption. We have confirmed a clear link to the current, widespread AWS operational incident. Please refer to the official AWS status page for updates on the overarching issue: (https://health.aws.amazon.com/health/status).
Posted Oct 20, 2025 - 20:37 UTC
Update
The team is starting to see the system recover. AWS is currently throttling the speed of requests which adversely impacts real-time systems. We are in active communication with AWS and their engineers are on the line with our team. You can monitor the official AWS status page here: (https://health.aws.amazon.com/health/status).
Posted Oct 20, 2025 - 19:51 UTC
Update
We are actively reviewing our systems in light of the current AWS incident. This issue is directly related to that event. For updates on the overall situation, please refer to the AWS status page here: (https://health.aws.amazon.com/health/status).
Posted Oct 20, 2025 - 19:35 UTC
Update
We are continuing to assess the extent of the disruption. The service interruption is associated with the reported AWS platform incident. We advise tracking the broader situation via the official AWS status page: (https://health.aws.amazon.com/health/status).
Posted Oct 20, 2025 - 19:03 UTC
Update
We're continuing our investigation into the specific impact on our service. The service interruption is connected to the ongoing, widespread AWS incident. You can monitor the official AWS status page here: (https://health.aws.amazon.com/health/status).
Posted Oct 20, 2025 - 18:31 UTC
Update
Our service interruption stems from the ongoing AWS incident, and we are actively investigating its impact. For real-time updates, please follow the AWS status page here: (https://health.aws.amazon.com/health/status).
Posted Oct 20, 2025 - 18:09 UTC
Update
We're still actively investigating this issue. The service interruption is connected to the ongoing AWS incident you can track here: (https://health.aws.amazon.com/health/status).
Posted Oct 20, 2025 - 17:35 UTC
Update
Our investigation is continuing. This service issue is tied to the current AWS incident. See the AWS status page for details: (https://health.aws.amazon.com/health/status).