Service disruption of Glia Platform affecting Insights

Incident Report for Glia

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 06:51 UTC

Monitoring

Our team has confirmed that all data is available and is actively being processed. Some customers may experience minor delays in viewing their processed data. Our systems continue to work through all outstanding information to ensure full completion.
Posted Oct 20, 2025 - 23:08 UTC