Infrastructure service provider reporting service disruption affecting Glia

Incident Report for Glia

Resolved

Our service provider has reported that the service has been restored, and Glia works as expected.
Posted Oct 20, 2025 - 11:06 UTC

Monitoring

We continue to communicate with our service provider to monitor the incident closely and follow their developments to fix it.
Posted Oct 20, 2025 - 10:30 UTC

Update

Our Phone Service Provider has reported a service disruption affecting phone engagements.
We are communicating and monitoring closely the incident and the developments to fix it.
Posted Oct 20, 2025 - 10:27 UTC

Update

The platform provider reported that mitigation steps have been applied. Services are still in recovery at this time.
Posted Oct 20, 2025 - 10:14 UTC

Identified

The platform provider reported that mitigation steps have been applied. Services are still in recovery at this time.
Posted Oct 20, 2025 - 10:12 UTC